• Report: #968318

Complaint Review: ATT Uverse Internet

  • Submitted: Mon, November 12, 2012
  • Updated: Mon, November 12, 2012

  • Reported By: moparmiami — Miami Florida United States of America
ATT Uverse Internet
Internet United States of America

ATT Uverse Internet UVERSE AT&T Extremely Poor Service, Garbage Equipment !!! Internet

What's this?
What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

SEO Reputation Management at its best!

This is my experience with ATT Uverse service. Extremely poor quality product is that they are using. I signed up for internet Uverse service. They mailed me a modem that worked good for 2 weeks then all of a sudden it just turned off.... there were no lights on what so ever and it just went totally blank. This modem they use is 2WIRE 3600HGV Model. This is a real piece of garbage ! Anyway, I called Uverse support and they mailed me a new modem. It came in 3 days later. I connected it. Worked great and after 30 minutes the WIFI connection just died. The wired connection to my desktop was still good. I was so surprised !!!

I called them again...stayed with the Tech for almost 1 hour and the wireless connection did not work. SO, they told me they will send a THIRD modem now. Remember all the modems they send me were 2WIRE 3600HGV model. The third modem came in and I plugged it in.... 3 minutes later... it just died. I was like WHAT the....?!?!?! anyway... i kept it connected and thought may be the lights will turn back on and the modem may be restarting... and guess what happend.... the modem started to burn ... and i could smell the burning smell... i plugged it out of the wall. Then i connected my second modem back on... so i could atleast surf the web on my desktop.

I called ATT and asked them if they have any other equipment in stock? they told me NO this is the only model of the modem which i can use and they told me to return the 2nd modem back (which still works on wired connection) and they will send out a 4th Modem ! LOL

This is SO Sad. May be they are using refurbished equipment or something. I googled this modem and I found a lot of threads with info that is telling me that this is a common problem with these modems.

I hope ATT can use better equipment. I know I will switch to another company very soon and NEVER EVER will go back to ATT. Also, my bill came out to $273 dollars instead of $135 which I was told when I placed my order, but that is a whole different story. There Tech support is horrible. ATT I hope you read this and contact me. I am a real person. I am not making this UP. I am extremely pissed off. 

This report was posted on Ripoff Report on 11/12/2012 08:07 PM and is a permanent record located here: http://www.ripoffreport.com/r/ATT-Uverse-Internet/internet/ATT-Uverse-Internet-UVERSE-ATT-Extremely-Poor-Service-Garbage-Equipment-Internet-968318. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report.

Click Here to read other Ripoff Reports on ATT Uverse Internet

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?