• Report: #940796

Complaint Review: Autocraft

  • Submitted: Thu, September 13, 2012
  • Updated: Thu, September 13, 2012

  • Reported By: chris — Springfield Oregon USA
2700 West 11th Avenue Eugene, OR 97402 eugene, Oregon United States of America

Autocraft They did not fix my car correctly and refuse to issue refund BEWARE!!! eugene, Oregon

What's this?
What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

SEO Reputation Management at its best!

I am very upset with Auto Craft and the repairs to my Mazda. I am including some of the pictures of my car and the things that are wrong with it. I am even more upset about my experience with them. I picked up my car just before they closed on Friday. I didn't have much time to examine it so I decided I would look at it better when I got home. When I got home Friday about 15 minutes after leaving Auto Craft I started to noticed the horrible job they did. Here are a few examples:

There is some paint run on the side fender that they painted
There is over spray on the black plastic next to the fender they painted.
There is more over spray on the fender.
The piece of the front grill is not attached and can fall off easily
The hood is not aligned correctly and has a bigger gap on one side then the other
The dash board inside is not connected properly and just slides off.
There are bolts missing under the hood where it attaches
There are a couple of missing black caps on the part above the hood of the car

(see attached pictures)

However I am most upset about my experience with them the next morning that landed me in the hospital

I arrived at their shop about 9:20 am the next morning (saturday). The employee that was there was named Chris. He was writing an estimate for another potential customer and he told me it would be a few minutes. As I waited 5 more customers arrived and he seemed to be the only one there to help us all. After waiting for my turn about 30 minutes in the lobby.
I then explained to him I had just received my car the day before and was unhappy. I took him out to the car and showed him everything and he agreed it was wrong and would fix it. We went back inside and he called Enterprise car rental and they were closed. He then called the Airport Enterprise which was opened on Saturday. He had another employee take me to the Eugene airport Enterprise. I was dropped off at the airport and told if there was any problems to cal Chris at the shop. When I walked
up to the Enterprise agent he told me they don't deal with Auto Craft and I would need a credit card to charge. I told him I didn't have a credit card and he basically told me oh well. I was now stranded at the Eugene Airport with no ride anywhere. I called Auto craft 22 times and their phone went straight to voice mail. I have my phone records to prove this.... I decided to try and take a taxi back to Auto Craft even though I had no money. I was hoping they would pay for it since they left me stranded. When I arrived back at Auto Craft I was really upset. I told Chris that he needed to pay the taxi and he did. I also told him I
wanted the keys back to my car and that I wanted to leave. Well he lost my keys, the keys I just handed to him 20 minutes prior. As he was looking for my keys I became very angry and started to have a hard time breathing. He finally found them and I left. I didn't get four blocks down the street before I couldn't breathe and could no longer drive. I had to call an ambulance as I was having an anxiety attack cause by all this. Now I have an ambulance and hospital bill to pay for.( which I have proof of as well )

This has been one of the worst experiences of my life. I want to get my car fixed correctly and was told by progressive that my car would look just as it did before the accident. This is not the case.

This report was posted on Ripoff Report on 09/13/2012 02:50 PM and is a permanent record located here: http://www.ripoffreport.com/r/Autocraft/eugene-Oregon-97402/Autocraft-They-did-not-fix-my-car-correctly-and-refuse-to-issue-refund-BEWARE-eugene-940796. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report.

Click Here to read other Ripoff Reports on Autocraft

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?