• Report: #293688

Complaint Review: Earthlink

  • Submitted: Fri, December 21, 2007
  • Updated: Fri, December 21, 2007

  • Reported By:Victorville California
PO BOX 7645 Nationwide U.S.A.

Earthlink Cargin me for eqipment and has not sent me the retunr label. Never used the service and there customer service never wants to assist you in any inquiry unless you are new customer. HORRIBLE SERIVCE from customer service dep Atlanta Georgia

What's this?
What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

SEO Reputation Management at its best!

Earthlink is chargin me 230.64 for an closed account every month that never was activated. 1st off I ordered wifi service with modem to be shipped over night. "$50"... I didnt get the equipment until 3 days later. Ok, it finally cam.. so i fugured that I would just install and activate the service... NO SERVICE available in my area. Called in servall times on the 3rd day to tech support for assostance to solve the probelm of not being able to obtain service.. Customer service does not understand english and does not listen to you when you are talking to them. but in a nut shell on the 5 day of tryin to get service I was informed that someone would give me a call to help me further. NO CALL.. on the 6th day I called in to cancel service.

The rep informed me that she would send out the return label for my equipment and refund my acocunt for any charges for overnight delivery and service charges. Ok i thouhgt moving on with my life... then I get a bill in the mail for 155.27! WTF i said where are these charges coming from. So I called in to inqury and the same customer service as usual nothing but they informed me agian that the labels for the return where being shipped out and no more charges are going to be on the account.

Then I get another bill in the mail showing that they tried to charge my account for 230.64.. I called back in and they gave me some 866 number to call but you need a mailbox number and they seem to not know the mailbox number. This has just been really frustrating when all I wanted was wifi service.

Victorville, California

This report was posted on Ripoff Report on 12/21/2007 03:30 PM and is a permanent record located here: http://www.ripoffreport.com/r/Earthlink/nationwide/Earthlink-Cargin-me-for-eqipment-and-has-not-sent-me-the-retunr-label-Never-used-the-serv-293688. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report.

Click Here to read other Ripoff Reports on Earthlink

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?