• Report: #978296

Complaint Review: Stereo One

Thank You

Read how Ripoff Report saves consumers millions.

  • Submitted: Wed, December 05, 2012
  • Updated: Wed, December 05, 2012

  • Reported By: Unhappy Customer — Milwaukee Wisconsin United States of America
Stereo One
5040 S 27th St Milwaukee, Wisconsin United States of America

Stereo One Stereo 1 Shoddy workmanship, waste of time and money! Milwaukee, Wisconsin

What's this?
What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

SEO Reputation Management at its best!

I took my car to Stereo One to have a remote starter/car alarm installed. At first I brought in a remote starter that I had purchased online and they gave me a quote saying it would be $150 and they could install it. I brought my car in and they attempted to install the remote starter but after bringing it home, I realized that it didn't work. I called Stereo One and they blamed the remote starter.

My next step was to get a remote starter that actually worked, so I purchased one from Stereo One: one that they should have been familiar with as it is one of their products. I had them install the new one, but it cost me $300 for just the unit. I decided to let them install it.

After about a day I realized that something was wrong with the remote starter as well as how it was installed. At times it wouldn't start, it definitely did not start up to 3,000 ft. which was promised, my car wouldn't unlock using the transmitter FOB, and the clock inside my car was off by about 20 minutes every time I started it in the morning. In order to get this fixed, I took it back to Stereo One and (without apologizing) said something must be off. So, they then installed ANOTHER remote starter (third one) saying that this one was more reliable.

I took my car home and tested it out. The car started up but after 10 seconds of running, it shut off. This one was even worse than the two I had installed before.

After this whole ordeal, which spanned about a month, and cost me over $450 I went back to Stereo One and had them uninstall it. This was the biggest headache/nightmare I could have imagined. After taking with the owner, they were able to give me back $250. So, I ended up eating $200 to have absolutely nothing done to my car except maybe have it messed up more by their incompetent "mechanics".

No wonder this place never has business. Every time I walked in there they were all sitting on the couch, which is in the middle of the store, doing nothing.

Please do not give these people your money! SCAM SCAM SCAM!


This report was posted on Ripoff Report on 12/05/2012 12:49 PM and is a permanent record located here: http://www.ripoffreport.com/r/Stereo-One/Milwaukee-Wisconsin-/Stereo-One-Stereo-1-Shoddy-workmanship-waste-of-time-and-money-Milwaukee-Wisconsin-978296. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report.

Click Here to read other Ripoff Reports on Stereo One

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?
Wal-Mart.com USA, LLC

Advertisers above have met our
strict standards for business conduct.



Ripoff Report Legal Directory