released
  • Report: #1071192

Complaint Review: Aamco on Austell Road in Marietta, GA

Thank You

Read how Ripoff Report saves consumers millions.

  • Submitted: Mon, July 29, 2013
  • Updated: Tue, July 30, 2013

  • Reported By: Bill — Austell Georgia
Aamco on Austell Road in Marietta, GA
2730 Austell Rd Suite 180 Marietta, GA 30008 Marietta, Georgia USA

Aamco on Austell Road in Marietta, GA Aamco of Marietta Aamco of Marietta,cMarietta Georgia

What's this?
What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

SEO Reputation Management at its best!

I took my 1997 Buick Century there on 6/21/2013 at 2:29 PM because it was diagnosed with a P1870 code in the transmission from Midas on Roswell Rd in Sandy Springs and Aamco on Austell Rd and they told me that the P1870 code was a code that my torque converter was failing and that it was going to cost me $450.00 to pull the transmission so, I okayed the pulling of the transmission and authorized the repair for the quoted $1850.00 and I asked the shop to call me before the work was performed but, they never called me. They called me on 6/27/2013 to tell me that my car was finished and that I could come pick up my car. I picked up my car and that following weekend I drove it to Glenwood, GA and the car started acting sluggish and started to bog as I was driving down the highway so, when I got to my destination I went to Advanced Auto and bought a new fuel filter and new spark plugs and changed the items named while I was at my family reunion. [continued below]....

..... When I was returning to Atlanta, GA on the 7/21/2013 my car started to have the same problems that I had going to Glenwood, GA so I called Aamco of Marietta that Monday morning and told them that my car was having problems and they told me to bring it in and they would fix the problem. When I got there they took my car for a test drive with me in it and couldn't find the problem on the first test drive so they drove my car back to the shop and the head transmission builder said that he would get someone else to test drive my car again to see if the other person could detect the problem. When they took my car out the second time they hooked up a scan-tron to the car to see where the problem where and it showed that my transmission wasn't shifting properly so the guy that was test driving the car said he would relay this information the the head builder so, I left my car there with them for 5 days. When I called them on 7/26/2013 to see if my car was finished the owner answered the phone to tell me that they were changing out the spark plugs that I put in the because they were getting a false reading when they were checking the transmission and that they were checking the sensors on my transmission and motor so I asked the owner Patrick to make sure they plugged all my sensor plugs back as they we checking them and he said that he would let the guy explain what he did when I came on 6/27/2013 to pick up my car. When I got there to get the car they told me that they changed the knock sensor for no charge and they would just exchange my plugs for the cost of the ones they replaced. As I was driving off my brake and ABS lights came on so I drove the car back to the shop and they hooked up the scanner and shut the lights off. I decided to drive to Knoxville, TN to pick up the rest of my clothes and it was driving fine until I was driving it back, the Brake and ABS lights came back on and my car started acting up again. I had to pull off the highway and shut the car off in order for the computer in the car to reset for the brake lights and ABS lights to reset. So the next day which was Sunday 7/28/2013 I went to look under the hood of my can and realized they did not plug my knock sensor plug back in and I plugged the plug back in and then my car wouldn't start. Come to find out that my battery was dead and had to replace it. On Monday 7/29/2013 I took my car back to Aamco to tell them my car was still having problems and they said that the problem was the knock sensor that was causing the problem. I took it to get a second opinion at Frank's Automotive in College Park, GA on Old National Highway and they hooked a scan-tron to my car and test drove my car and they told me that the transmission wasn't shifting properly, it shifted hard from first to second and stayed in second up to 60 mph and skip third gear and go to fourth and not go into lock up. I called the Aamco corporate headquarters and all you get when you call them is the operator and the switch you to a answering machine. So I am out $1850.00 and no solution. All my problems that accrued after my transmission was worked on worked until Aamco of Marietta worked on my car.


This report was posted on Ripoff Report on 07/29/2013 09:26 PM and is a permanent record located here: http://www.ripoffreport.com/r/Aamco-on-Austell-Road-in-Marietta-GA/Marietta-Georgia-30008/Aamco-on-Austell-Road-in-Marietta-GA-Aamco-of-Marietta-Aamco-of-MariettacMarietta-Georg-1071192. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report.

Click Here to read other Ripoff Reports on Aamco on Austell Road in Marietta, GA

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?

Advertisers above have met our
strict standards for business conduct.



Ripoff Report Legal Directory