• Report: #1066144
Complaint Review:


  • Submitted: Thu, July 11, 2013
  • Updated: Thu, July 11, 2013

  • Reported By: Cheri — Milwaukee Wisconsin
Internet USA

Eagletron aka TrackerCam.com Non-working product with no support whatsoever  Internet

REBUTTAL BOX™ | Respond to this Report! | Consumer Comment

What's this?
Corporate Advocacy Program

Show customers why they should trust your business over your competitors...

What's this?
What's this?
Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

Does your business have a bad reputation?
Fix it the right way.
Corporate Advocacy Program™

Set the record straight:
Arbitration Program

SEO Reputation Management at its best!

 I ordered a LancPod which is basically a robotic tripod meant for Sony camcorders with LANC connections. It hooks up via USB and has movement controls and is supposedly operable remotely.

I hooked up the unit on several computers (Including a very high-end desktop with full power rear-usb ports) and on every system I got an error that the unit could not be "moved" via the movement control software due to "not enough power" going to the control pod unit. I can understand that happening on a laptop or smaller computer, but a full-size desktop with full-power rear USB ports? That seems a bit strange.

So on the pop-up that warns you about the lack-of-power, it urges you to order the "optional" USB power cable which is a propietary USB cable with a wall plug coming out the side that is supposed to provide all of the power you need to operate the unit. That cost quite a bit with shipping, but I had no choice but to order it to make it work according to the pop-up I got.

When I got the special plug and tried it out, it worked for all of a few minutes and then the pop-up came back and the unit stopped working after the pop-up appeared. Unplugged it and started from scratch and the same thing kept happening. The unit would work no more than a few minutes at a time then crap out.

Also the unit doesn't seem to be able to be controlled remotely. I took hours to go through their overly-complex software and was unable to make any remote movement work whatsoever.  The software seemed very crappily made and lost connection at the drop of a hat.

Now I've been trying to contact Eagletron to return the unit and they will NOT respond to any emails. They responded to my original product questions nice and fast, but when it came to problems with my unit, these people are not-to-be-found!


This report was posted on Ripoff Report on 07/11/2013 07:41 AM and is a permanent record located here: http://www.ripoffreport.com/reports/eagletron/internet/eagletron-aka-trackercamcom-non-working-product-with-no-support-whatsoevernbsp-interne-1066144. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year.

Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report. READ: Foreign websites steal our content

Click Here to read other Ripoff Reports on Eagletron

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Search Tips
Report & Rebuttal
Respond to this report!
What's this?
Also a victim?
What's this?
Repair Your Reputation!
What's this?