X  |  CLOSE
Report: #1469719

Complaint Review: pro auto - oklahoma city,ok oklahoma city, ok

  • Submitted:
  • Updated:
  • Reported By: Kenneth — Oklahoma City United States
  • pro auto
    1041 sw 59 oklahoma city
    oklahoma city,ok, oklahoma city, ok
    United States

pro auto pro auto charged me twice for a valve cover job that they did not fix.valve covers are still leaking. oklahoma city,ok oklahoma city, ok

Show customers why they should trust your business over your competitors...

Is this
Ripoff Report
About you?
Ripoff Report
A business' first
line of defense
on the Internet.
If your business is
willing to make a
commitment to
customer satisfaction
Click here now..

On 10-06-2018 I took my car to pro auto 1041 sw 59 okla city, ok recommened by a friend to get valve cover job done pro auto charged me $381.74..they did not put any parts on my car. just valve cover sealant, inwhich my car is leaking worse than before.I called Pro auto and told them my car is still leaking oil MR.Justin told me that he could not put any new valve covers on my car because his carrier did not have the valve covers for my car.I then asked MR.JUSTIN why did you take my car apart if you could not do the job correctly. I took the car back on 11-30-2018  with the valve covers that I ordered.PRO AUTO put the parts on and charged me $259.87 for a job they did not do correctly the first time. altogether i paid out of pocket.$641.61 for a valve cover job that is still leaking oil with the engine light on now. i went and got a second opinion to find out why my engine light is on. [continued below]....

..... the check engine sensor was left unplugged causing damge to the connecting wires.inwhich if I would have took the car back to PRO AUTO i know they would have charged me again.PRO AUTO has clearly scammed me and I want justice. I have all my receipts and the diagnostic reports from the master mechanic at valvoline on 29th and sunnylane showing the cause of damage to my car. thank you

Kenny Taylor

This report was posted on Ripoff Report on 12/17/2018 10:52 AM and is a permanent record located here: https://www.ripoffreport.com/reports/pro-auto/oklahoma-cityok-oklahoma-city-ok-73109/pro-auto-pro-auto-charged-me-twice-for-a-valve-cover-job-that-they-did-not-fixvalve-cove-1469719. The posting time indicated is Arizona local time. Arizona does not observe daylight savings so the post time may be Mountain or Pacific depending on the time of year. Ripoff Report has an exclusive license to this report. It may not be copied without the written permission of Ripoff Report. READ: Foreign websites steal our content

Search for additional reports

If you would like to see more Rip-off Reports on this company/individual, search here:

Report & Rebuttal
Respond to this report!
Also a victim?
Repair Your Reputation!